Serveur minecraft

Comment transformer un Raspberry Pi en un routeur de voyage sécurisé par un réseau privé virtuel – Un bon serveur Minecraft

Le 28 juin 2019 - 11 minutes de lecture

Publicité

Souhaitez-vous écrire votre mot de passe sur un morceau de papier et le coller sur votre front? Probablement pas. Pourtant, se connecter à un réseau Wi-Fi public est presque aussi stupide.

Toutefois, vous n’avez peut-être pas le choix si vous êtes sur la route et souhaitez rester en contact. Un VPN peut vous protéger, mais chaque appareil doit se connecter séparément, à moins que vous n'utilisiez un routeur de voyage comme intermédiaire.

Vous n'en avez pas? Ne vous inquiétez pas, vous pouvez en créer un avec un Raspberry Pi. C’est le choix idéal pour un routeur de voyage DIY VPN, laissez-nous vous expliquer comment en construire un.

Ce dont vous aurez besoin

Pour commencer à construire un routeur de voyage Raspberry Pi VPN, vous aurez besoin des éléments suivants:

  • Raspberry Pi (Pi 3 ou Raspberry Pi Zero W préféré) avec étui
  • Un seul adaptateur Wi-Fi USB (deux, si vous utilisez un ancien Raspberry Pi)
  • Une carte microSD avec au moins 8 Go de stockage
  • Un lecteur de carte SD
  • Une alimentation de haute qualité
  • PC avec un client SSH installé
  • Un abonnement VPN avec support OpenVPN

Il est possible d’utiliser des modèles Pi sans Wi-Fi intégré, mais vous aurez besoin de deux adaptateurs Wi-Fi USB, ou d’un adaptateur capable de fonctionner en mode point d’administration / accès et en mode client.

Au lieu d’une distribution Linux standard, vous devrez installer OpenWRT sur votre carte SD pour en faire un routeur à part entière. Vous pouvez utiliser une autre distribution Linux si vous préférez, mais OpenWRT fournit une interface Web pratique pour la configuration lorsque vous n'êtes pas à la maison.

Si vous utilisez Windows, vous devez également installer PuTTY ou un autre client SSH pour Windows.

4 façons simples d'utiliser SSH sous Windows



4 façons simples d'utiliser SSH sous Windows
SSH est la solution de facto pour accéder en toute sécurité aux terminaux distants sous Linux et autres systèmes de type UNIX. Si vous souhaitez accéder à un serveur SSH distant, vous devez télécharger un client SSH ….
Lire la suite

avant de commencer.

Étape 1: Installez OpenWRT

Écran Etcher SD Flashing Tool

Tout d’abord, téléchargez le micrologiciel OpenWRT correspondant à votre modèle de Raspberry Pi. Vous pouvez trouver les images les plus récentes sur le wiki OpenWRT.

Décompressez le fichier téléchargé en utilisant 7zip ou un autre gestionnaire d'archives de fichiers approprié, puis collez le fichier IMG sur votre carte avec Etcher.

Cet outil devrait détecter votre carte SD automatiquement; il vous suffit de sélectionner votre fichier image, de sélectionner le lecteur correct par lettre, puis de cliquer sur Flash.

Une fois cela fait, replacez votre carte microSD dans votre Raspberry Pi et laissez-la démarrer.

Étape 2: Configuration initiale

Par défaut, OpenWRT utilise une adresse IP statique de 192.168.1.1, qui est l’adresse de passerelle par défaut de nombreux routeurs. Vous devrez changer cela pour éviter les conflits. Connectez votre Pi à votre PC avec un câble Ethernet. vous devrez peut-être définir une adresse IP statique

Comment afficher et modifier votre adresse IP sous Windows 7, 8 et 10



Comment afficher et modifier votre adresse IP sous Windows 7, 8 et 10
Vous pouvez utiliser votre ordinateur sans même connaître votre adresse IP, mais voudriez-vous savoir comment vérifier? Voici comment vérifier ou modifier rapidement votre adresse IP sous Windows.
Lire la suite

sur votre PC d'abord.

Plutôt que de gérer la configuration à l'aide de LuCI, l'interface Web d'OpenWRT, vous allez le faire manuellement pour vous assurer que la configuration est correctement définie. Chargez PuTTY ou votre client SSH et connectez-vous à 192.168.1.1 d'abord avec le nom d'utilisateur racine.

Vous recevrez un premier avertissement de sécurité lors de votre première connexion. cliquez Oui et procéder. C’est une bonne idée à ce stade de définir un mot de passe. faire cela en tapant passwd à la fenêtre du terminal.

Configurer les paramètres du réseau et du pare-feu

Vous devez éditer deux fichiers –/ etc / config / network et / etc / config / pare-feu—Vous pouvez continuer plus avant. Commencez par taper ce qui suit pour éditer le fichier:

vim / etc / config / network

Ensuite, appuyez sur I pour modifier le texte et inclure les éléments suivants:

interface de configuration 'loopback'
option ifname 'lo'
option proto 'statique'
option ipaddr '127.0.0.1'
option masque de réseau '255.0.0.0'

interface de configuration 'LAN'
type d'option 'pont'
option ifname 'eth0'
option force_link '1'
option proto 'statique'
option ipaddr '192.168.38.1'
option masque de réseau '255.255.255.0'
option ip6assign '60'

interface de configuration 'wwan'
option proto 'dhcp'
option peerdns '0'
option dns '8.8.8.8 8.8.4.4' ## serveurs DNS Google

interface de configuration 'vpnclient'
option ifname 'tun0'
option proto 'aucune'

Une fois que vous avez terminé, appuyez sur le bouton Esc clé et type: wq pour sauvegarder et quitter. Basculez ensuite l'attention sur le fichier de configuration du pare-feu:

vim / etc / config / pare-feu

Robinet je pour éditer, puis trouver (ou ajouter) une zone pour la section WAN, qui devrait ressembler à ceci:

zone de configuration
nom de l'option wan
réseau d'option 'wan wan6 wwan'
entrée d'option ACCEPTER
sortie d'option ACCEPTER
option forward REJECT
option masq 1
option mtu_fix 1

Type redémarrer et attendez que le Raspberry Pi redémarre avec une nouvelle adresse IP: 192.168.38.1.

Étape 3: mise à jour et installation des packages

Ensuite, vous devrez mettre à jour OpenWRT. Pour ce faire, vous allez emprunter le Wi-Fi interne du Pi et le configurer pour vous connecter à votre réseau Wi-Fi existant. Vous devrez peut-être modifier votre adresse IP statique en 192.168.38.2 ou une adresse similaire dans cette plage pour vous permettre de vous connecter.

Une fois connecté, tapez l’adresse IP de votre Raspberry Pi dans votre navigateur pour accéder au tableau de bord administrateur OpenWRT. Utilisez votre nom d'utilisateur et votre mot de passe pour accéder, puis allez à Réseau> Sans fil. Vous ne devriez voir qu'un seul périphérique Wi-Fi pour le moment, alors cliquez sur Balayage pour trouver votre réseau Wi-Fi, puis Rejoindre le réseau quand vous le trouvez.

Vous devrez entrer votre mot de passe Wi-Fi sous WPA Passphrase, avant de frapper Soumettre.

Vous devriez maintenant voir les paramètres de connexion pour votre connexion Wi-Fi. Aller à Réglages avancés et mettez votre Code postal pour correspondre à votre emplacement; votre Wi-Fi pourrait ne pas fonctionner autrement.

Reconnectez-vous à votre Pi en utilisant une nouvelle adresse IP sur SSH (acceptant l'avertissement de clé de sécurité RSA). Vous devez d'abord mettre à jour votre appareil en tapant:

mise à jour opkg

Gardez un œil dessus en tapotant Y lorsque vous y êtes invité.

Installation des pilotes USB Wi-Fi

Une fois toutes les mises à jour installées, installez tous les pilotes nécessaires à votre adaptateur USB Wi-Fi. Cela est nécessaire pour vous connecter aux points d'accès Wi-Fi lorsque vous êtes en déplacement. Vous installerez également les outils dont vous aurez besoin pour les connexions VPN avec OpenVPN, ainsi que nano, un éditeur de fichier terminal facile à utiliser.

C’est là que votre méthode peut varier; J'avais un adaptateur Wi-Fi pour le jeu de puces RT2870. Par conséquent, les commandes suivantes devraient également fonctionner:

installer installer kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb kmod-usb-core kmod-usb-uhci kmod-usb-ohci kmod-usb2 usbutils openvpn-opensl luci-app-openvpnnano
ifconfig wlan1 up
redémarrer

Si vous ne possédez pas d'adaptateur Wi-Fi pour chipset RT2870 ou si vous avez un doute, branchez votre adaptateur Wi-Fi et tapez ce qui suit dans le terminal SSH:

opkg installer kmod-usb-core kmod-usb-uhci kmod-usb-ohci kmod-usb2 usbutils
lsusb

Une fois les fichiers installés, vous verrez une liste des périphériques connectés. Recherchez celles qui font référence à un adaptateur sans fil et recherchez les instructions d'installation appropriées pour votre appareil.

Écran de fenêtre OpenWRT Putty Terminal

Étape 4: Configuration du point d'accès Wi-Fi

Si votre adaptateur USB Wi-Fi est connecté, vous pouvez maintenant configurer les deux connexions Wi-Fi. Retournez au tableau de bord LuCI, sous Sans fil, et supprimez les deux connexions réseau. Le dispositif radio0 est votre Wi-Fi intégré, tandis que radio1 est votre adaptateur USB Wi-Fi.

Configurez votre réseau Wi-Fi intégré en cliquant sur Ajouter. Assurez-vous que:

  • Mode est réglé sur Point d'accès
  • ESSID est défini sur un nom de réseau de votre choix; la valeur par défaut est OpenWRT
  • Réseau est réglé sur lan
  • Sous Sécurité sans fil, Cryptage est réglé sur WPA2-PSK
  • Clé est défini sur un mot de passe approprié

Une fois que vous avez terminé, appuyez sur sauvegarder puis retournez au Sans fil menu. Suivez les instructions précédentes pour la connexion initiale afin de définir la radio1 périphérique (votre adaptateur USB Wi-Fi) à votre réseau existant. C’est également à cet endroit que vous devrez analyser et modifier les réseaux lorsque vous vous trouvez dans un nouvel emplacement.

Menu sans fil OpenWRT LuCI Dashboard

Vous devez maintenant avoir deux connexions Wi-Fi en cours d'exécution, une en tant que point d'accès pour vos périphériques Wi-Fi et l'autre en tant que connexion Internet de votre périphérique à votre réseau Wi-Fi existant. Essayez de vous connecter à votre Pi à ce stade avec votre smartphone ou votre ordinateur portable pour confirmer que cela fonctionne.

Si cela fonctionne, déconnectez votre Pi de la connexion Ethernet avec votre PC.

Étape 5: connexion au VPN et modifications finales

Vous aurez besoin d’un fichier de configuration OpenVPN (OVPN) pour connecter votre Pi au fournisseur et au serveur VPN de votre choix. Si vous en avez un, chargez-le sur votre Pi à l'aide d'un client SCP tel que WinSCP, où vous pourrez vous connecter avec votre nom d'utilisateur et votre mot de passe administrateur.

Renommez le fichier en vpnclient.ovpn et le télécharger dans le / etc / openvpndossier. Suivez les instructions du site Web OpenWRT pour configurer votre Pi pour les connexions VPN. Le seul léger changement concerne la section 4 pour la configuration du profil du client VPN, pour lequel vous n’aurez pas besoin du chat outil pour insérer votre vpnclient.ovpn fichier, car il est déjà en place.

Dès que vous avez terminé, votre connexion VPN devrait s'activer automatiquement. Vérifiez que votre adresse IP sortante a changé; Si ce n’est pas le cas, redémarrez votre Pi et vérifiez que votre connexion est active.

Trouvez cela en allant au OpenVPN section de LuCI, listée sous Prestations de service en haut du tableau de bord. Si c'est connecté, vpnclient sera répertorié comme Oui sous le Commencé colonne.

OpenWRT LuCI Dashboard Menu OpenVPN

Étape 6: enregistrez votre appareil en Wi-Fi public

Votre Pi est presque prêt à ce stade, mais si vous êtes déjà connecté à un réseau Wi-Fi public, vous saurez que vous devrez généralement vous authentifier à l’aide d’un portail captif pour payer ou enregistrer votre appareil. Parce que votre Pi est maintenant configuré pour se connecter automatiquement via VPN (et devrait empêcher la connexion autrement), ces portails seront généralement bloqués.

Pour contourner ce problème, configurez votre adaptateur USB Wi-Fi pour qu'il corresponde à l'adresse MAC avec un périphérique que vous pouvez utiliser pour vous connecter et vous authentifier d'abord sur un réseau Wi-Fi public, tel que votre smartphone. Une fois que vous avez cela, tapez:

nano /etc/init.d/wan-changer

Dans la fenêtre d’édition, ajoutez ce qui suit (en remplaçant l’espace réservé XX pour votre MAC) et appuyez sur Ctrl + X, suivi par Y sauver.

#! / bin / sh /etc/rc.common

START = 10

début() 
 uci set wireless. @ wifi-iface[1].macaddr = 'XX: XX: XX: XX: XX: XX'
 réseau uci commit

Enfin, exécutez les commandes suivantes pour que le script s’exécute automatiquement au démarrage de votre Pi:

chmod + x /etc/init.d/wan-changer
/etc/init.d/wan-changer enable

Redémarrez pour vérifier que tout fonctionne correctement. Vous devez également rechercher d'éventuelles fuites DNS pour vous assurer que votre connexion VPN fonctionne correctement. La plupart des fournisseurs de VPN offrent un outil qui vous aidera à cela.

Wi-Fi sécurisé partout où vous allez, garanti

Votre Raspberry Pi devrait maintenant être configuré et prêt à fonctionner en tant que routeur de voyage VPN, ce qui signifie que vous pouvez naviguer en toute sécurité dans tous les hôtels et cafés que vous visitez. Grâce au tableau de bord LuCI, vous pouvez vous connecter facilement à tout nouveau réseau Wi-Fi via votre navigateur Web.

Voir notre liste des meilleurs services VPN

Les meilleurs services VPN



Les meilleurs services VPN
Nous avons compilé une liste de ce que nous considérons comme les meilleurs fournisseurs de services de réseau privé virtuel (VPN), regroupés par prime, gratuitement et par torrent.
Lire la suite

pour trouver un service VPN adapté à vos besoins.

Explorez plus au sujet de: tutoriels de projets de bricolage, Raspberry Pi, routeur, Voyage.

Commentaires

Laisser un commentaire

Votre commentaire sera révisé par les administrateurs si besoin.